Ассоциация ЭБНИТ    ИРБИС-корпорация    Вики-Ирбис    Online/CHM справка Ирбис    FTP-сервер
АРМ Комплектатор :  ИРБИС Irbis
 
Не работает заполнение поля из справочника
Пользователь: DenisSerov (IP-адрес скрыт)
Дата: 08, September, 2015 13:53

День добрый. Подскажите может кто сталкивался с такой проблемой.

Попробую описать детально...
Запускаю комплектатор - для редактирования записи запускаю из комплектатора каталогизатор - иду в добавочные и добавляю поле.
захожу в меню созданного поля и пытаюсь редактировать поле 461 - Автор...
при редактировании выскакивает менюшка справочника из которого по идее можно автора просто вставить что бы не вписывать его вручную... и тут обнаруживается что данные из справочника не вставляются... все ищется, но вставляться не хочет... В чем может быть дело?
Причем если просто запустить каталогизатор без комплектатора, то все работает нормально, ищется, вставляется и т.д.

Заранее благодарен.

Re: Не работает заполнение поля из справочника
Пользователь: Сорокина Лариса (IP-адрес скрыт)
Дата: 08, September, 2015 15:14

DenisSerov написал(а):
-------------------------------------------------------
> День добрый. Подскажите может кто сталкивался с
> такой проблемой.
>
> Попробую описать детально...
> Запускаю комплектатор - для редактирования записи
> запускаю из комплектатора каталогизатор - иду в
> добавочные и добавляю поле.
> захожу в меню созданного поля и пытаюсь
> редактировать поле 461 - Автор...
> при редактировании выскакивает менюшка справочника
> из которого по идее можно автора просто вставить
> что бы не вписывать его вручную... и тут
> обнаруживается что данные из справочника не
> вставляются... все ищется, но вставляться не
> хочет... В чем может быть дело?
> Причем если просто запустить каталогизатор без
> комплектатора, то все работает нормально, ищется,
> вставляется и т.д.
>
> Заранее благодарен.

Разница в значении параметра EKP= в файлах ini для Комплектатора и Каталогизатора. Думаю, что в одном случае для ввода автора в добавленное поле 461 подается словарь БД CMPL, а в другом - словарь БД ЭК. Для переноса данных используется один и тот же формат, но прописанные в этом формате квалификаторы не используются в словаре CMPL. Поэтому переноса не происходит.
Введите имя БД ЭК в Настройке Комплектатора



Редактировано 1 раз. Последний раз 08.09.2015 15:20 пользователем Сорокина Лариса.

Re: Не работает заполнение поля из справочника
Пользователь: DenisSerov (IP-адрес скрыт)
Дата: 10, September, 2015 10:44

Сорокина Лариса написал(а):
-------------------------------------------------------
> DenisSerov написал(а):
> --------------------------------------------------
> -----
> > День добрый. Подскажите может кто сталкивался с
> > такой проблемой.
> >
> > Попробую описать детально...
> > Запускаю комплектатор - для редактирования
> записи
> > запускаю из комплектатора каталогизатор - иду в
> > добавочные и добавляю поле.
> > захожу в меню созданного поля и пытаюсь
> > редактировать поле 461 - Автор...
> > при редактировании выскакивает менюшка
> справочника
> > из которого по идее можно автора просто
> вставить
> > что бы не вписывать его вручную... и тут
> > обнаруживается что данные из справочника не
> > вставляются... все ищется, но вставляться не
> > хочет... В чем может быть дело?
> > Причем если просто запустить каталогизатор без
> > комплектатора, то все работает нормально,
> ищется,
> > вставляется и т.д.
> >
> > Заранее благодарен.
>
> Разница в значении параметра EKP= в файлах ini для
> Комплектатора и Каталогизатора. Думаю, что в одном
> случае для ввода автора в добавленное поле 461
> подается словарь БД CMPL, а в другом - словарь БД
> ЭК. Для переноса данных используется один и тот же
> формат, но прописанные в этом формате
> квалификаторы не используются в словаре CMPL.
> Поэтому переноса не происходит.
> Введите имя БД ЭК в Настройке Комплектатора

Вы имеете в виду отредактировать в ini комплектатора параметр EKP=?

Re: Не работает заполнение поля из справочника
Пользователь: Сорокина Лариса (IP-адрес скрыт)
Дата: 11, September, 2015 12:40

DenisSerov написал(а):
-------------------------------------------------------
> Сорокина Лариса написал(а):
> --------------------------------------------------
> -----
> > DenisSerov написал(а):
> >
> --------------------------------------------------
>
> > -----
> > > День добрый. Подскажите может кто сталкивался
> с
> > > такой проблемой.
> > >
> > > Попробую описать детально...
> > > Запускаю комплектатор - для редактирования
> > записи
> > > запускаю из комплектатора каталогизатор - иду
> в
> > > добавочные и добавляю поле.
> > > захожу в меню созданного поля и пытаюсь
> > > редактировать поле 461 - Автор...
> > > при редактировании выскакивает менюшка
> > справочника
> > > из которого по идее можно автора просто
> > вставить
> > > что бы не вписывать его вручную... и тут
> > > обнаруживается что данные из справочника не
> > > вставляются... все ищется, но вставляться не
> > > хочет... В чем может быть дело?
> > > Причем если просто запустить каталогизатор
> без
> > > комплектатора, то все работает нормально,
> > ищется,
> > > вставляется и т.д.
> > >
> > > Заранее благодарен.
> >
> > Разница в значении параметра EKP= в файлах ini
> для
> > Комплектатора и Каталогизатора. Думаю, что в
> одном
> > случае для ввода автора в добавленное поле 461
> > подается словарь БД CMPL, а в другом - словарь
> БД
> > ЭК. Для переноса данных используется один и тот
> же
> > формат, но прописанные в этом формате
> > квалификаторы не используются в словаре CMPL.
> > Поэтому переноса не происходит.
> > Введите имя БД ЭК в Настройке Комплектатора
>
> Вы имеете в виду отредактировать в ini
> комплектатора параметр EKP=?

Предлагаю сделать это через кнопку "Настройка" на панели инструментов АРМ Комплектатор

Re: Не работает заполнение поля из справочника
Пользователь: DenisSerov (IP-адрес скрыт)
Дата: 15, September, 2015 10:07

спасибо, сегодня попробую

Re: Не работает заполнение поля из справочника
Пользователь: EleAle (IP-адрес скрыт)
Дата: 13, April, 2016 10:23

Добрый день!

Ирбис 64 v2014.1.
Наши сотрудники столкнулись с такой же ситуацией. Не переносится из словаря в поле ввода автор, в фамилии которого есть апостроф. (например о'Брайен). С остальными фамилиями проблем нет. В АРМ Каталогизатор, запущенном не через Комплектатор, а напрямую, тоже все в порядке.
Мозговой штурм позволил выявить, что если запустить Ирбис 64 v2014.1 из клиента v2012.1 - такой ошибки нет. Замечу, что все 6 обновлений для клиента v2014.1 были выполнены.
Как преодолеть, не менять же комплектаторам клиента на старого?!



Извините, только зарегистрированные пользователи могут писать в этом форуме.
This forum powered by Phorum.